|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19149 Can't get PHP to work in ~userdir directories
Submitted: 2002-08-28 10:18 UTC Modified: 2002-08-30 10:15 UTC
From: weldon at excelsus dot com Assigned:
Status: Closed Package: Apache2 related
PHP Version: 4CVS-2002-08-28 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: weldon at excelsus dot com
New email:
PHP Version: OS:


 [2002-08-28 10:18 UTC] weldon at excelsus dot com
I see the notice about Apache not working with 2.0.40 but I download the lastest stable snap and the one the linked on the bug page.  Both do the same thing. 

I have identical httpd.conf files and default php.ini files on the two servers

One running FreeBSD 4.6.1-RELEASEp7, Apache 2.0.39 and PHP 4.2.2

The second running FreeBSD 4.6.2-RELEASE, Apache 2.0.40 and PHP 4.2.3-dev (lastest snapshot)

The second server interprets files in user directories
(directories with ~whatever) as text files, the first server interprets the php files correctly.

Both servers run php files in other directories correctly.

I can't find anything odd about the httpd.conf file.  the public_html dirs in the httpd.conf files are using the directives for Directory /, and the httpf.conf files are identical anyway.

The permissions and ownership of the php files are the same on both servers.

Of course, this can be an Apache 2.0.40 issue.



Configure command:
'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql' '--with-tsrm-pth'


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-28 10:22 UTC]
It most likely is.  Try the latest unstable snapshot (should be labeled PHP 4.3.0-dev)... and if that still doesn't work, re-open this.
 [2002-08-28 10:22 UTC] weldon at excelsus dot com
PHP versions mentioned are not correct

1st server is 4.2.2
2nd server is 4.3.0-dev (latest snapshot) (not 4.2.3)
 [2002-08-30 10:15 UTC] weldon at excelsus dot com
Tried snapshot today "200208300600" and it worked.

But also tried clearing cache from explorer, so it could have been only a caching problem with explorer OR it was a problem but I don't know which snap fixed it.

PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 17:05:54 2022 UTC