|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18958 Unable to Fork
Submitted: 2002-08-17 11:56 UTC Modified: 2002-11-06 11:28 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: ron at simplydigi dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.2.2 OS: Windows 2000 Server SP 3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: ron at simplydigi dot com
New email:
PHP Version: OS:


 [2002-08-17 11:56 UTC] ron at simplydigi dot com
We upgraded from version 4.06 to 4.21 and then 4.22 and then 4.3alpha 2  and the following commands no longer worked for us we kept getting Unable to Fork errors

exec("C:\perl\bin\perl.exe d:\pathto\"); 
exec("C:\pathto\killprogram.exe perl.exe");

We were trying to run custom programs and purchased products
after we upgraded to the new versions  Photopost 3.06 with Imagemagick 4.4.8 no longer worked either we kept getting the unable to fork error

Our System Specs
Windows 2000 server Service Pack 3
Active Perl Latest Version
MySQL latest version
Memory 512Meg


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-17 11:58 UTC] ron at simplydigi dot com
Sorry Imagemagick version was 5.4.8
 [2002-11-05 04:42 UTC] twa at carlbro dot dk
I have the same problem on PHP 4.2.3. For my project this is a very critical bug.

Just to make sure, I tried everything from giving access to all user to the bin file to giving specific access to cmd.exe and settting the security level on the ISS virtual webserver to none.
 [2002-11-05 04:51 UTC] twa at carlbro dot dk
By the way my server looks like this:

Windows 2000 Server v5.0.2195 (running Service Pack 3)
(with windows updates latest installed on the October 9th)
PHP 4.2.3
MySQL 3.23.49
 [2002-11-05 06:09 UTC] twa at carlbro dot dk
Maybe this bug duplicates this one:
 [2002-11-06 04:14 UTC] twa at carlbro dot dk
One of my friends successfully made it work on a Windows 2000 Server with Service Pack 3 - So maybe is has nothing to do with the SP level. But when we where about to test the differences between the two servers the harddrive broke.

Right now he is just trying to install a new server. So I'll write back if we find out something new.
 [2002-11-06 11:22 UTC] twa at carlbro dot dk
Got it fixed. It was some secuiry script applied that set some C:\winnt\system32\cmd.exe security settings. We didn't notice them before we compared two servers (one working and one not-working one)
 [2002-11-06 11:24 UTC]
 [2002-11-06 11:26 UTC]
Oops.. setting to feedback to see if the original author got it fixed.
 [2002-11-06 11:26 UTC] ron at simplydigi dot com
I had the same issue and it turned out that because I clone my servers it was a permissions issue. You have to make sure that all of your IUSR and IWAM users match on the local machine and the domain. Once I did this everything worked fine. Here is a Microsoft Q article in their knowledge base that shows you how to do it if you do not know Q297989
 [2002-11-06 11:28 UTC]
Bogus, then.
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Jun 11 02:03:37 2023 UTC