php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #18348 Reboot hangs because of error message
Submitted: 2002-07-15 07:57 UTC Modified: 2002-07-15 08:35 UTC
From: jim at scottkraft dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.2.1 OS: Windows 2000 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jim at scottkraft dot com
New email:
PHP Version: OS:

 

 [2002-07-15 07:57 UTC] jim at scottkraft dot com
PHP 4.2.1 is installed as a cgi module on a Windows 2000 Server machine with an 800 Mhz Intel Pentium III processor using IIS 5.

When I configure the php.ini file to activate the extension module "php_ctype.dll" to use for error checking in my scripts, everything seems to work until it is necessary to reboot the system. Upon attempting to reboot, the system stops with the following message:
WARNING
ctype: Unable to initialize module
Module compiled with debug=0, thread-safety=1 module API = 20020429
PHP compiled with debug=0, thread-safety=1 module API = 20010901
These options need to match.

followed by:
SERVICE CONTROL MANAGER
At least one service or driver failed
during system startup.  Use Event Viewer
to examine the event log for details.

After clicking "OK" to both of these messages, the system finishes rebooting and seems to work. But this causes a problem when rebooting remotely since the system hangs until someone is physically able to click through these messages at the server site.

When I go back and comment out the line:
"extension=php_ctype.dll" in the php.ini file, the messages cease.

I have another system running Windows 98 2nd Ed. with a 500 Mhz AMD K6-2 processor using PWS 4 with PHP 4.2.1 set up the same way. With the php_ctype.dll module activated in php.ini, I do not receive any messages upon reboot and the module seems to work correctly.

Why do files from the same archive (php-4.2.1-Win32.zip) give this message/problem on the Win2000 Server?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-07-15 08:35 UTC] hholzgra@php.net
your php_ctype.dll is from a newer PHP release
than your php itself, so it can't be loaded due
to API changes (see the API numbers in the error
messages: "20020429" vs. "20010901")

make sure all your PHP components are from the
same release
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 01:05:46 2022 UTC