php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #18235 season parameter for date()
Submitted: 2002-07-09 01:41 UTC Modified: 2017-01-11 06:39 UTC
Votes:5
Avg. Score:4.6 ± 0.8
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: daniel at reflexionsdesign dot com Assigned:
Status: Wont fix Package: Date/time related
PHP Version: 4.2.1 OS: RedHat Linux 7.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: daniel at reflexionsdesign dot com
New email:
PHP Version: OS:

 

 [2002-07-09 01:41 UTC] daniel at reflexionsdesign dot com
Because the seasonal begin/end dates can be computed (and are often hard to remember), it would be helpful to have a "season" parameter for the date() function so that, e.g., if it were currently the spring, "date("X",time())" would return the string "spring".  Thanks!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-14 13:19 UTC] kris dot craig at gmail dot com
Is there any reason why this simple feature request has remained in "Open" status for 7 years now without any action?!  This should take all of 5 minutes to add in there.  And if there's some reason why it shouldn't be, then why hasn't anyone marked the status accordingly?
 [2009-09-14 13:39 UTC] derick@php.net
If it is so simple, where is your patch? Seriously though... find a link to the algorithms and find somebody who's interested enough in implementing it.
 [2010-12-03 18:00 UTC] jani@php.net
-Package: Feature/Change Request +Package: Date/time related
 [2017-01-11 06:39 UTC] heiglandreas@php.net
-Status: Open +Status: Wont fix
 [2017-01-11 06:39 UTC] heiglandreas@php.net
As that is highly dependent on your current geographic location it's nothing to be added to a datetime-library.

Seasons are the "other way round" on the northern and southern hemisphere and arround the equator there are no seasons at all.

So sorry, you will need to set that up with userland code.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC