php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #17950 Parameters do not seem to work
Submitted: 2002-06-24 13:39 UTC Modified: 2002-06-24 13:44 UTC
From: ips at compatcart dot co dot uk Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 4.2.1 OS: Win 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ips at compatcart dot co dot uk
New email:
PHP Version: OS:

 

 [2002-06-24 13:39 UTC] ips at compatcart dot co dot uk
I am hoping that this is not a bug but I have tried different versions and still get the same outcome, I would apreciate anyone's input. I am new to PHP so I have set it up as default (install.txt instructions)

Running Apache 2.0.39 (win32) PHP/4.2.2-dev (or other versions) with PHP 4.2.1 (or other versions) on win 2K, the parameters I pass to a php script do not seem to work. Using my www.portland.co.uk account it works.

I have used the following code
***************
<?php
  ?>The parameter you passed me was <? print $loc;
?>
***************
and when I call it with test.php?loc=mytest I simply get "The parameter you passed me was "

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-24 13:44 UTC] cox@php.net
In PHP 4.2.0, the 'register_globals' setting default changed to
be off. See http://www.php.net/release_4_2_0.php for more info.
We are sorry about the inconvenience, but this change was a necessary
part of our efforts to make PHP scripting more secure and portable.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 25 07:05:45 2022 UTC