php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #17164 please group sections in the functions reference
Submitted: 2002-05-12 12:03 UTC Modified: 2004-08-09 14:02 UTC
Votes:4
Avg. Score:4.0 ± 1.2
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: verdy_p at wanadoo dot fr Assigned: goba (profile)
Status: Not a bug Package: Documentation problem
PHP Version: 4.2.0 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: verdy_p at wanadoo dot fr
New email:
PHP Version: OS:

 

 [2002-05-12 12:03 UTC] verdy_p at wanadoo dot fr
I suggest that you organize the very long list sections (now more than 110) in the functions reference into distinct parts to help navigation and easier find related sections. I suggest the folowing order (tabulated format):

Part	Category	Section	ref. .php	English Title
I	PHP language	I.1	variables	Variables
I	PHP language	I.2	array	Arrays
I	PHP language	I.3	funchand	Functions
I	PHP language	I.4	classobj	Classes/Objects
I	PHP language	I.5	overload	Object overloading
I	PHP language	I.6	errorfunc	Errors and Logging
I	PHP language	I.7	info	PHP Options/Info
I	PHP language	I.8	misc	Misc.
II	Text handling	II.1	strings	Strings
II	Text handling	II.2	ctype	ctype
II	Text handling	II.3	gettext	gettext
II	Text handling	II.4	pcre	PCRE
II	Text handling	II.5	regex	Regexps
II	Text handling	II.6	url	URLs
II	Text handling	II.7	mbstring	Multi-Byte String
II	Text handling	II.8	iconv	iconv
II	Text handling	II.9	recode	Recode
II	Text handling	II.10	fribidi	FriBiDi
II	Text handling	II.11	pspell	Pspell
II	Text handling	II.12	aspell	Aspell
III	XML & Markup	III.1	xml	XML
III	XML & Markup	III.2	xslt	XSLT
III	XML & Markup	III.3	domxml	DOM XML
III	XML & Markup	III.4	qtdom	qtdom
IV	Numeric functions	IV.1	math	Math
IV	Numeric functions	IV.2	gmp	GMP
IV	Numeric functions	IV.3	bc	BC math
IV	Numeric functions	IV.4	datetime	Date/time
IV	Numeric functions	IV.5	calendar	Calendar
V	Compression	V.1	zlib	Zlib
V	Compression	V.2	zip	Zip
V	Compression	V.3	bzip2	Bzip2
VI	Graphics & multimedia	VI.1	image	Image
VI	Graphics & multimedia	VI.2	pdf	PDF
VI	Graphics & multimedia	VI.3	cpdf	ClibPDF
VI	Graphics & multimedia	VI.4	fdf	FDF
VI	Graphics & multimedia	VI.5	ming	Ming (flash)
VI	Graphics & multimedia	VI.6	swf	SWF
VII	Security & encryption	VII.1	crack	Crack
VII	Security & encryption	VII.2	mcrypt	mcrypt
VII	Security & encryption	VII.3	mhash	mhash
VII	Security & encryption	VII.4	openssl	OpenSSL
VIII	Server integration	VIII.1	outcontrol	Output Control
VIII	Server integration	VIII.2	http	HTTP
VIII	Server integration	VIII.3	session	Sessions
VIII	Server integration	VIII.4	msession	Msession
VIII	Server integration	VIII.5	apache	Apache
IX	Local OS interfaces	IX.1	filesystem	Filesystem
IX	Local OS interfaces	IX.2	dir	Directories
IX	Local OS interfaces	IX.3	dio	Direct IO
IX	Local OS interfaces	IX.4	readline	Readline
IX	Local OS interfaces	IX.5	ncurses	ncurses
IX	Local OS interfaces	IX.6	exec	Program Execution
IX	Local OS interfaces	IX.7	pcntl	PCNTL
IX	Local OS interfaces	IX.8	posix	POSIX
IX	Local OS interfaces	IX.9	sem	Semaphore
IX	Local OS interfaces	IX.10	shmop	shmop
IX	Local OS interfaces	IX.11	java	PHP / Java Integration
IX	Local OS interfaces	IX.12	printer	Printer
IX	Local OS interfaces	IX.13	w32api	W32api
IX	Local OS interfaces	IX.14	com	COM
X	Networking	X.1	network	Network
X	Networking	X.2	sockets	Sockets
X	Networking	X.3	ftp	FTP
X	Networking	X.4	curl	CURL
X	Networking	X.5	xmlrpc	XMLRPC function
X	Networking	X.6	wddx	WDDX
X	Networking	X.7	snmp	SNMP
X	Networking	X.8	nis	YP/NIS
X	Networking	X.9	dotnet	.NET
X	Networking	X.10	yaz	YAZ
XI	Mails & messaging	XI.1	mail	Mail
XI	Mails & messaging	XI.2	mailparse	mailparse
XI	Mails & messaging	XI.3	vpopmail	vpopmail
XI	Mails & messaging	XI.4	imap	IMAP
XI	Mails & messaging	XI.5	cyrus	Cyradm
XI	Mails & messaging	XI.6	ircg	IRC Gateway
XII	SQL databases	XII.1	mysql	MySQL
XII	SQL databases	XII.2	msql	mSQL
XII	SQL databases	XII.3	pgsql	PostgreSQL
XII	SQL databases	XII.4	odbc	ODBC
XII	SQL databases	XII.5	dbase	dBase
XII	SQL databases	XII.6	dba	dba
XII	SQL databases	XII.7	dbm	DBM
XII	SQL databases	XII.8	dbplus	DB++
XII	SQL databases	XII.9	dbx	dbx
XII	SQL databases	XII.10	fbsql	FrontBase
XII	SQL databases	XII.11	filepro	filePro
XII	SQL databases	XII.12	ibase	InterBase
XII	SQL databases	XII.13	oci8	OCI8
XII	SQL databases	XII.14	oracle	Oracle
XII	SQL databases	XII.15	sybase	Sybase
XII	SQL databases	XII.16	mssql	MS SQL Server
XII	SQL databases	XII.17	ifx	Informix
XII	SQL databases	XII.18	ingres	Ingres II
XII	SQL databases	XII.19	ovrimos	OvrimosSQL
XII	SQL databases	XII.20	sesam	SESAM
XIII	Organize & search	XIII.1	ldap	LDAP
XIII	Organize & search	XIII.2	mcal	MCAL
XIII	Organize & search	XIII.3	icap	ICAP
XIII	Organize & search	XIII.4	ccvs	CCVS
XIII	Organize & search	XIII.5	notes	Lotus Notes
XIII	Organize & search	XIII.6	hwapi	Hyperwave API
XIII	Organize & search	XIII.7	hyperwave	Hyperwave
XIII	Organize & search	XIII.8	mnogo	mnoGoSearch
XIII	Organize & search	XIII.9	muscat	muscat
XIV	Commerce	XIV.1	cybercash	Cybercash
XIV	Commerce	XIV.2	cybermut	CyberMUT
XIV	Commerce	XIV.3	pfpro	Verisign Payflow Pro

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-12 12:05 UTC] jan@php.net
we are already working on that.
 [2002-05-12 12:17 UTC] sander@php.net
Erm... something messed up... fixed that...
 [2002-07-24 11:15 UTC] paulo at isnet dot com dot br
Great idea... Another one is to list new extensions/functions somewhere, because it's hard to know when something new appears - I usually find a new extension by quickly looking through the list and try to see if something catches my attention.
 [2002-07-24 11:52 UTC] goba@php.net
We already have a manual.xml.in file at

  http://cvs.php.net/co.php/phpdoc/RFC/manual.xml.in

with groupings already accepted by the PHP documentation
guys (there were not too many opinions about it, but at
least no arguments against it). Are problems with this are
that we still need to work out how to make new chunks of
those <section>s which is not the default (see the ref
pages with <section>s), and how to control the TOCs
display [deepness] we get.. All these both in the DSSSL
sheets and in the XSL sheets. So there is still some
work to do.
 [2004-08-07 18:25 UTC] vrana@php.net
Same as http://bugs.php.net/24861
 [2004-08-08 19:59 UTC] goba@php.net
We track this issue at the bug Jakub pointed to (this makes this bugreport bogus, not the content).
 [2004-08-09 13:01 UTC] verdy_p at wanadoo dot Fr
May be the same as http://bugs.php.net/24861
But THIS report is MUCH older than newer bug 24861 that caught this one.

So THIS bug 17164 was not bogous: close it if you want, because the solution proposed in Bug 24861 is a good reply to this bug report. But get sure to make the job in newer bug 24861...

Thanks.
 [2004-08-09 13:45 UTC] vrana@php.net
And http://bugs.php.net/2352 is even older than this :-).
 [2004-08-09 14:02 UTC] goba@php.net
As I have said it is not the content which makes this bogus, but it is being a duplicate (the bogus status is used for duplicates). What do we choose from the duplicates is our freedom. There were three bugs for this stuff. I have choosen the latest one to track the progress there, since none of the bugs really added any value to the discussion (we already have a grouping in place, just the infrastructure is not ready yet to handle it).
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Nov 13 17:01:31 2019 UTC