php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16973 modules compiled without error but won't work
Submitted: 2002-05-02 15:04 UTC Modified: 2002-05-02 23:03 UTC
From: matthiaskontny at gmx dot de Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.2.0 OS: Linux 2.4.17
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: matthiaskontny at gmx dot de
New email:
PHP Version: OS:

 

 [2002-05-02 15:04 UTC] matthiaskontny at gmx dot de
compiled php 4.2.0 into apache 2.0.35
no errors during confiure or compile, but make test marks >40 tests as failed, e.g. bz2 support was configured in, says yes and found, compilation completed without errors, but bzopen("blubb.bz2","w"); causes an error:
Warning: bzopen(): Unable to open file in /var/www/htdocs/bz2test.php on line 2
no matter what the permissions are (all owned by sub.users, apache runs under sub.users as well)

http://topf.hn.org/test.log.bz2 contains the configure parameters and the make test output

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-05-02 22:28 UTC] matthiaskontny at gmx dot de
had a look at the error output in /var/log/php.log

half the errors result from:

- too many arguments for count (in the code: count($arr, COUNT_NORMAL))
- file doesn't exist 
- includes don't work, paths other than in php.ini given
- functions not found (aggregate* don't exist, neither in includes nor are mentioned in the manual)

so half the test fails because of this, but bzopen and a couple other function still don't work
 [2002-05-02 23:03 UTC] yohgaki@php.net
Thank you for repoting problems.
We manage 1 bug per report. I'll make this bogus.
Please make sure to provide short & complete script for bug report.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 22 15:01:24 2020 UTC