php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16812 odbc_connect not work! Please help urgently
Submitted: 2002-04-24 22:32 UTC Modified: 2002-04-25 02:35 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: sunisachai at yahoo dot com Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.0CVS-2002-04-2 OS: window 2000 advance server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sunisachai at yahoo dot com
New email:
PHP Version: OS:

 

 [2002-04-24 22:32 UTC] sunisachai at yahoo dot com
I use :
Server:window 2000 advance server 
IIS 5.0
PHP version :php-4.0.6-Win32
set DSN in Data Source(ODBC).User DSN =test and point to
Microsoft Access (*.mdb)   when i use this code

  $db=odbc_connect("test'","","");
  $rc =odbc_exec($db,"select * from pass");
  while(odbc_fetch_row($rc)){
    print(odbc_result($rc,1)."<br>");
   }

It has error :
Warning: SQL error: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified, SQL state IM002 in SQLConnect in F:\works\work\webpage\test\t.php on line 20

Warning: Supplied argument is not a valid ODBC-Link resource in F:\works\work\webpage\test\t.php on line 21

Warning: Supplied argument is not a valid ODBC result resource in F:\works\work\webpage\test\t.php on line 22

I try change add dsn in system dsn that not work and say same error messages.

It try it in window98,window 2000 Professional,window me.
It work.
Please help

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-25 00:08 UTC] kalowsky@php.net
Please make sure your ODBC control panel has this DSN defined.  From what it sounds, your data source isn't being defined which makes this not a bug for PHP.
 [2002-04-25 02:35 UTC] sunisachai at yahoo dot com
I set odbc right,but it dose not work .
In this afternoon i read some webpages and they suggest me to set something like this:
  odbc_connect("test","","",SQL_CUR_USE_ODBC);
That work!
Thanks
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 05:09:35 2022 UTC