|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #16248 "Inclusion error" with Apache 1.3.24 and PHP 4.1.2 (VirtualHost set)
Submitted: 2002-03-25 00:04 UTC Modified: 2002-06-02 19:26 UTC
Avg. Score:4.7 ± 0.7
Reproduced:7 of 7 (100.0%)
Same Version:6 (85.7%)
Same OS:6 (85.7%)
From: jma at brandeis dot edu Assigned:
Status: Closed Package: Apache related
PHP Version: 4.1.2 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: jma at brandeis dot edu
New email:
PHP Version: OS:


 [2002-03-25 00:04 UTC] jma at brandeis dot edu
Well, the closest I've come to my bug is 14563, but I have some evidence that it's different.

I was running Apache with PHP 4.0.6 and everything worked fine.  I saw the 4.1.2 fix was up, so I installed the new version (SAPI, from the ZIP) over the old version.

I would get the error message:
Failed opening '/program files/apache group/apache/htdocs/test.php' for inclusion (include_path='c:\php4\pear') in Unknown on line 0

So, after messing with it for a couple hours, trying to debug my install (maybe I specified something incorrectly), I decided to reinstall everything -- Apache, PHP, and MySQL.

Upon reinstallation, before doing anything funky, I tried running a simple php page containing only phpinfo() -- it worked!

At this point, I added one VirtualHost to Apache's httpd.conf (and set a couple NameVirtualHost values).  Now, PHP stopped working, and I got that inclusion error message again.

With a VirtualHost set, no changing of php.ini or httpd.conf would get PHP to work.

So, I reverted back to PHP 4.0.6 -- everything works fine... VirtualHosts and all.

I'm happy to provide more info if it would help.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-03-26 10:40 UTC] shouvik dot hyd at cxknetworks dot com
I struggled on the problem for 8 hours, tried whatever any site having the least to do with PHP had to say, but no success...

also it shows that php4ts.dll contains the text 'c:\php4\pear'. But do not try to hack into the DLL. I tried. Does not help.

go back to 4.0.6
 [2002-05-23 15:47 UTC] st at finantech dot com
Exactly the same problem!

I was upgrading my web server and decided to try
the new php 4.2.1. It was impossible!. My os is linux
so i think it's a php issue
 [2002-06-02 17:41 UTC]
You have to change include_path in php.ini. Add "." then I should work. "c:\php4\pear" is automatic added. 

Regards, Kai
 [2002-06-02 19:26 UTC]
This should be fixed if no php.ini is used, btw.
If someone still gets the error, they most likely have not
updated php4ts.dll on their system or they have 2 or more
of those..

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Dec 07 06:01:29 2023 UTC