php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #15701 Unable to use DB2 and MSSQL concurrantly
Submitted: 2002-02-24 16:57 UTC Modified: 2002-09-11 11:10 UTC
From: cshobe at softhome dot net Assigned:
Status: Not a bug Package: Sybase (dblib) related
PHP Version: 4.1.1 OS: Linux 2.4.17 (compiled sources)
Private report: No CVE-ID: None
 [2002-02-24 16:57 UTC] cshobe at softhome dot net
Problem the first:
  Unable to compile PHP with any of the following options:
    --with-sybase & --with-ibm-db2
    --with-sybase & --with-unixodbc
  due to conflicts.

Problem the second:
  --with-sybase-ct does not work with FreeTDS, even when
  editting the Zend/Makefile file and removing -lsybtcl,
  -lintl -lcomn and -lcs, leaving the -lct, from
  libZend_la_LDFLAGS.

Problem the third:
  Cannot use FreeTDS via ODBC object through PHP.  Null
  data is returned for every query.  I have no idea how to
  track this further.  Perhaps it is because one cannot
  connect to two ODBC datasources concurrently?

Thanks for any support!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-11 01:39 UTC] kalowsky@php.net
A) only one bug per report please.
B) try a newer release, or even a dev snapshot, thanks :)
 [2002-09-11 11:10 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 19 10:01:27 2019 UTC