php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1448 sybase_fetch_row() fills a single space character in all empty fields in a row
Submitted: 1999-05-24 17:00 UTC Modified: 1999-09-04 13:45 UTC
From: pni at rubicon dot no Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 3.0.7 OS: Redhat Linux 5.2
Private report: No CVE-ID: None
 [1999-05-24 17:00 UTC] pni at rubicon dot no
Quite easy to reproduce, just do a sybase_fetch_row() and a strlen() on columns that is empty ('') in the database. The strlen will show 1 and there will be a single space character as data. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-09-04 13:45 UTC] rasmus at cvs dot php dot net
Not a bug, that's how Sybase works.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 14:01:25 2019 UTC