php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14384 Configuration error for apxs
Submitted: 2001-12-07 22:05 UTC Modified: 2001-12-07 22:32 UTC
From: chandra at fuse dot net Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.1.0 OS: Linux - Redhat 7.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chandra at fuse dot net
New email:
PHP Version: OS:

 

 [2001-12-07 22:05 UTC] chandra at fuse dot net
I am running the following

./configure --with-sql=/usr/local/mysql/bin/mysql
--with-apxs=/usr/local/apache/bin/apxs

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache module support via DSO through APXS...
Usage: apxs -g [-S <var>=<val>] -n <modname>
       apxs -q [-S <var>=<val>] <query> ...
       apxs -c [-S <var>=<val>] [-o <dsofile>] [-D
<name>[=<value>]]
               [-I <incdir>] [-L <libdir>] [-l <libname>]
[-Wc,<flags>]
               [-Wl,<flags>] <files> ...
       apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>]
<dsofile> ...
       apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>]
<dsofile> ...
Sorry, I was not able to successfully run APXS.  Possible
reasons:
1.  Perl is not installed;
2.  Apache was not compiled with DSO support
(--enable-module=so);
3.  'apxs' is not in your path.
configure: error: ;


I have specified the right  path to apxs and made sure that
apache was built with dso support.

The following is the out put of httpd -l

Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_include.c
  mod_autoindex.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_setenvif.c


I would appreciate any help on this matter.

Thanks


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-07 22:17 UTC] rasmus@php.net
User error.

Your httpd -L clearly shows that you do not have mod_so which means you did not actually build your Apache with mod_so support.
 [2001-12-07 22:20 UTC] yohgaki@php.net
This is most likely not a bug.
How did you install apache?
Do you still have Apache related RPM installed?
If so, uninstall Apache RPM and install Apache from
source again, make sure you enable DSO support. 
If you still have problem reopen this report.

-- Yasuo
 [2001-12-07 22:32 UTC] yohgaki@php.net
Sorry From/OS/PHP Version/Summary has been changed.
Mozilla 0.9.6+ seems cache problem for dynamic pages :(

-- Yasuo 
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 22:01:25 2020 UTC