php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #14051 Invalid return in realpath if extra slash
Submitted: 2001-11-14 04:53 UTC Modified: 2001-11-20 10:39 UTC
From: g dot noel at symphonieonline dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.0.6 OS: Windows
Private report: No CVE-ID: None
 [2001-11-14 04:53 UTC] g dot noel at symphonieonline dot com
<?php
echo '['.realpath('//tmp').']';
?>

On Windows : [/\tmp] -> Correct : [c:\tmp]
On Linux   : [/tmp]

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-14 04:56 UTC] sniper@php.net
Update the #14049 bug report. DO NOT OPEN NEW REPORTS ABOUT SAME THING!!

 [2001-11-20 10:39 UTC] g dot noel at symphonieonline dot com
In my opinion it's not the same problem as bug #14049 !?

 [2002-05-17 05:06 UTC] preston dot bannister at cox dot net
Note that "//tmp" or "\\tmp" looks like a UNC path (due to the // prefix), and therefore cannot be reduced.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 10:01:28 2019 UTC