php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13848 transparent sessions not w3c compliant
Submitted: 2001-10-27 09:08 UTC Modified: 2001-10-28 11:10 UTC
From: duane at optushome dot com dot au Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: duane at optushome dot com dot au
New email:
PHP Version: OS:

 

 [2001-10-27 09:08 UTC] duane at optushome dot com dot au
transparent sessions don't appear to be w3c compliant, in that when a url is not cookied, it appears as, eg

<a href="index.php?id=xyz&PHPSESSION=3982982">
where it should be
<a href="index.php?id=xyz&amp;PHPSESSION=3982982">

see http://www.htmlhelp.com/tools/validator/problems.html#amp

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-27 09:15 UTC] derick@php.net
Not a bug, see this part from php.ini-recommended:

; The separator used in PHP generated URLs to separate arguments.
; Default is "&".
;arg_separator.output = "&amp;"
 [2001-10-28 10:36 UTC] sniper@php.net
This applies to PHP 4.0.6 and above. 
So update first.

--Jani

 [2001-10-28 11:10 UTC] jeroen@php.net
Shouldn't &amp; be made the default? Since that's the only correct thing, and at least since HTML 2.0 &amp;-style quoting was required.

Or are there browsers doing it wrong? Bad browsers in that case, but it could be a reason to not change the default: Apache for examples has also some workarounds in their default httpd.conf for buggy browsers.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 16 23:03:39 2021 UTC