php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13588 Crash when making a normal string to an array
Submitted: 2001-10-07 16:39 UTC Modified: 2002-06-04 10:25 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:1 of 2 (50.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: roelkw at xs4all dot nl Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.6 OS: WinXP build 2600 (final)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roelkw at xs4all dot nl
New email:
PHP Version: OS:

 

 [2001-10-07 16:39 UTC] roelkw at xs4all dot nl
When you create a variable and make it a string, like this:

$test = "hey";

and later on I change this to an array, like this:

$i++;
while ($row = mysql_fetch_array($res)) {
  $test[$i]["id"] = $row["id"];
  $test[$i]["name"] = $row["name"];
  $i++;
}

Then PHP/Apache crashes on this line:
  $test[$i]["name"] = $row["name"];
If I comment that line out, there's no crash!

Weird, isn't it?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-04 04:59 UTC] edink@php.net
Cannot reproduce this on PHP 4.2.1. Please try the new version and reopen if the problem is still there.
 [2002-06-04 06:18 UTC] roelkw at xs4all dot nl
Now it works for me too, but with an old version it produced this error. Why does it take such a long time before I recieve an answer?
 [2002-06-04 06:32 UTC] mfischer@php.net
> Why does it take such a long time before I recieve an answer?

Because we're all volunteers, no one gets paid, everyone has a real job, etc. Welcome to opensource.
 [2002-06-04 10:17 UTC] roelkw at xs4all dot nl
I know it's open source and I really do understand it can take a litte bit of time to answer, but this has taken 8 months.. I think that's a bit too long. I really appreciate your work and I use it a lot, but I think this is really too long.
 [2002-06-04 10:25 UTC] mfischer@php.net
Then I'm sad that you've to realize that it plain isn't too long. We have had reports taking longer then this to get responses and there are even quite a few reports open with issues which are much older then yours. In a community where no one has a contract to work on something, people 'can' gome and go and in worst cases reports never get processed. It's just a fact, in the opensource world there's nothing like "this is really too long".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Mar 07 15:01:23 2021 UTC