php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13021 ip2long erroneous in actually creating a long
Submitted: 2001-08-29 06:09 UTC Modified: 2002-01-16 06:56 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: dido at wise-guys dot nl Assigned:
Status: Closed Package: Network related
PHP Version: 4.0.6 OS: Linux 2.2.17
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dido at wise-guys dot nl
New email:
PHP Version: OS:

 

 [2001-08-29 06:09 UTC] dido at wise-guys dot nl
Actually the given example of 'equivalent' URLs will return in:

The following URLs are equivalent:
http://www.php.net/, http://208.247.106.187/, and http://-789091653/
The last one, obviously being erroneous.
 
http://www.php.net/manual/en/function.ip2long.php 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-16 06:00 UTC] lobbin@php.net
Works for me on 4.1.0, please verify.
 [2002-01-16 06:55 UTC] dido at wise-guys dot nl
Hm, I can't seem to reproduce it anymore, we've upgraded our OS to 2.4.13-ngpt, although I doubt it has anything to do with it.
Thanks for looking anyway :)
 [2002-01-16 06:56 UTC] derick@php.net
Then we close it
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 23:03:13 2021 UTC