php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13005 with-fdftk option not allowing configure to complete
Submitted: 2001-08-28 15:04 UTC Modified: 2001-08-29 11:02 UTC
From: dcobbs at caci dot com Assigned:
Status: Not a bug Package: FDF related
PHP Version: 4.0.6 OS: solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
41 + 16 = ?
Subscribe to this entry?

 
 [2001-08-28 15:04 UTC] dcobbs at caci dot com
I am having great difficulty in configuring php 4.0.6 to use fdftk4_05. In following the directions I copied the file FDFToolkitForUNIX/HeadersAndLibraries/headers/fdftk.h to /usr/local/include/FdfTk.h

I also copied FDFToolkitForUNIX/HeadersAndLibraries/solaris/C/libfdftk.so to /usr/local/lib/libfdftk.so


Here is a slightly altered version of my configure command:
./configure --with-apxs=/Apache/bin/apxs --enable-force-cgi-redirect --with-oci8=/oracle --with-xml --without-mysql --with-fdftk=/usr/loca

Here is the abbreviated output from that command:
checking whether to enable ctype support... no
checking for CURL support... no
checking for CyberCash support... no
checking for cybermut support... no
checking whether to include old xDBM support... no
checking whether to enable DBA... no
checking for GDBM support... no
checking for NDBM support... no
checking for Berkeley DB2 support... no
checking for Berkeley DB3 support... no
checking for DBM support... no
checking for CDB support... no
checking whether to enable DBA interface... no
checking whether to enable the bundled dbase library... no
checking whether to enable dbx support... no
checking for DOM support... no
checking whether to enable exif support... no
checking for FrontBase SQL92 (fbsql) support... no
checking for fdftk support... yes
checking for FDFOpen in -lfdftk... no
checking for FDFOpen in -lFdfTk... no
./configure: test: argument expected



Here is the abbreviated output from the config.log:
checking for bc style precision math functions... no
checking for BZip2 support... no
checking whether to enable calendar conversion support... no
checking CCVS Support... no
checking whether to include cpdflib support... no
checking whether to include crack support... no
checking whether to enable ctype support... no
configure:14521: checking for DBM support
configure:14748: checking for CDB support
configure:14760: checking whether to enable DBA interface
configure:14925: checking whether to enable the bundled dbase library
configure:15113: checking whether to enable dbx support
configure:15299: checking for DOM support
configure:15773: checking whether to enable exif support
configure:15961: checking for FrontBase SQL92 (fbsql) support
configure:16303: checking for fdftk support
configure:16399: checking for FDFOpen in -lfdftk
configure:16418: cc -o conftest -g  -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=260 -DMOD_SSL=206104
 -DMOD_PERL -DUSE_PERL_SSI -DEAPI -DUSE_EXPAT  -R/usr/ucblib -L/usr/ucblib conftest.c -lfdftk
-L/usr/local/lib -lm -lcrypt -lresolv -lresolv -lm -ldl -lnsl -lsocket  -lsocket 1>&5
ld: fatal: library -lfdftk: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
  #line 16407 "configure"
  #include "confdefs.h"
  /* Override any gcc2 internal prototype to avoid an error.  */
  /* We use char because int might match the return type of a gcc2
      builtin and then its argument prototype would still apply.  */
  char FDFOpen();
 
  int main() {
  FDFOpen()
  ; return 0; }
configure:16399: checking for FDFOpen in -lFdfTk
configure:16418: cc -o conftest -g  -D_POSIX_PTHREAD_SEMANTICS -DSOLARIS2=260 -DMOD_SSL=206104
 -DMOD_PERL -DUSE_PERL_SSI -DEAPI -DUSE_EXPAT  -R/usr/ucblib -L/usr/ucblib conftest.c -lFdfTk
-L/usr/local/lib -lm -lcrypt -lresolv -lresolv -lm -ldl -lnsl -lsocket  -lsocket 1>&5
ld: fatal: library -lFdfTk: not found
ld: fatal: File processing errors. No output written to conftest
configure: failed program was:
  #line 16407 "configure"
  #include "confdefs.h"
  /* Override any gcc2 internal prototype to avoid an error.  */
  /* We use char because int might match the return type of a gcc2
      builtin and then its argument prototype would still apply.  */
  char FDFOpen();

  int main() {
  FDFOpen()
  ; return 0; }




Also here is the value of my LD_LIBRARY_PATH environment variable:
echo $LD_LIBRARY_PATH
/usr/local/lib


Please help.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-28 15:28 UTC] dcobbs at caci dot com
I copied FDFToolkitForUNIX/HeadersAndLibraries/solaris/C/libfdftk.so to /usr/local/lib/libFdfTk.so not to /usr/local/lib/libfdftk.so as previously stated.
 [2001-08-29 11:02 UTC] sniper@php.net
User error:

By installing gcc and binutils I realized that I had a corrupted libFdfTk.so file. I downloaded the FDF software again, moved the files to
the proper locations and spellings, and retried the configure command, it
worked perfectly.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Oct 18 08:01:26 2019 UTC