php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12737 index bug concerning "00" and "08"
Submitted: 2001-08-14 06:03 UTC Modified: 2001-08-14 06:26 UTC
From: mwijnen at cs dot uu dot nl Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 4.0.5 OS: Linux 2.2.19 #10 SMP i686
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mwijnen at cs dot uu dot nl
New email:
PHP Version: OS:

 

 [2001-08-14 06:03 UTC] mwijnen at cs dot uu dot nl
Using 0 padded integers as index for an array:
	- does not work for 0 and 8
	- scrambles the order of the elements

-------
$a[00] = "string0";
$a[01] = "string1";
$a[02] = "string2";
$a[03] = "string3";
$a[04] = "string4";
$a[05] = "string5";
$a[06] = "string6";
$a[07] = "string7";
$a[08] = "string8";
$a[09] = "string9";

echo implode(";", $a);
--------

This yields:

string9;string1;string2;string3;string4;string5;string6;string7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-14 06:26 UTC] derick@php.net
Not a bug, 09 is interpreted as octal, and octal 08/09 does not exist.

Derick
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 00:01:26 2019 UTC