php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12423 float point assignment error
Submitted: 2001-07-27 09:25 UTC Modified: 2002-01-21 09:27 UTC
From: noIdea at mailbox dot sk Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.0.6 OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: noIdea at mailbox dot sk
New email:
PHP Version: OS:

 

 [2001-07-27 09:25 UTC] noIdea at mailbox dot sk
It's easy to describe:

echo odbc_result($ref, "column");
$a = (double) odbc_result($ref, "column");
echo "   /   " . $a;

output:

55.25   /   55

If I'm assigned result from odbc_result to some variable, it's ALWAYS convertet from DOUBLE to INTEGER.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-21 09:27 UTC] kalowsky@php.net
I'm unable to reproduce this using PostgreSQL/ODBC.  
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 10:01:24 2020 UTC