php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11722 unable to fork with system command
Submitted: 2001-06-27 03:23 UTC Modified: 2001-07-23 11:52 UTC
From: erik at pbmusic dot nl Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.6 OS: win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: erik at pbmusic dot nl
New email:
PHP Version: OS:

 

 [2001-06-27 03:23 UTC] erik at pbmusic dot nl
I am running a appache 1.3 webserver with PHP 4.1

wen i use the command: system('md xxx');
everything works fine

now i have installed php4.6 and i get the message 
"unable to fork" wenn i run the same script.
what am i doing wrong?
Do i need to start the process in background with an other program??? 

Many thanks in advance.
PHP is perfect.

Erik

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-27 22:07 UTC] sniper@php.net
You have a time machine? Can you give me a copy of PHP 4.1?  :)

I assume you meant PHP 4.0.1? 
system() works for me just fine with PHP 4.0.6.
Are you sure you have installed PHP correctly?
Is it run as CGI or as Apache module?


 [2001-07-23 11:52 UTC] kalowsky@php.net
closed due to no user feedback.  if this bug is still valid, please reopen the bug.
 [2002-07-06 07:04 UTC] sorinv at yahoo dot com
If you want to run a windows command that is an internat command (not exe, it is carried out by the cmd.exe process) prefix your command with 'cmd /C '.

Example:

system('cmd /C md xxx');

This will make it work.

Sorin
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 08 23:01:28 2023 UTC