php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11089 Variables passed to COM objects causing errors.
Submitted: 2001-05-24 12:13 UTC Modified: 2001-06-12 12:45 UTC
From: skipsey at skipsey dot net Assigned:
Status: Closed Package: COM related
PHP Version: 4.0.4pl1 OS: Win2k
Private report: No CVE-ID: None
 [2001-05-24 12:13 UTC] skipsey at skipsey dot net
If I create two new COM objects

  $first = new COM (object1.function);
  $second = new COM (object2.function);

then 

  $a_var = $second->task;

  $first->dosomething($a_var);

I get the following message -

Warning: Invoke() failed: Type mismatch. in D:\Data\docs\whorl_test\connect2.php on line..

the rest of the script I'm running seems fine, it only stops working when I get to this line. The data being passed as $a_var is in the form of an array.

Thanks for your time,

John.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-25 13:56 UTC] phanto@php.net
duplicate of #7691.
 [2001-06-12 12:45 UTC] jmoore@php.net
Should be fixed in latest CVS
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 26 06:01:26 2019 UTC