php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10847 nl2br - buggy
Submitted: 2001-05-14 07:54 UTC Modified: 2001-05-14 08:02 UTC
From: djlopez at mail dot com Assigned:
Status: Closed Package: Strings related
PHP Version: 4.0.5 OS: Debian/Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: djlopez at mail dot com
New email:
PHP Version: OS:

 

 [2001-05-14 07:54 UTC] djlopez at mail dot com
$foo = "\n";
$foo = nl2br($foo);

// $foo is now "<br />"  !!!!!!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-14 08:01 UTC] sniper@php.net
This is the correct behaviour. It's now xhtml compatible.
No bug.


--Jani

 [2001-05-14 08:02 UTC] sniper@php.net
This is the correct behaviour. It's now xhtml compatible.
No bug.


--Jani

 [2001-05-14 08:02 UTC] derick@php.net
Not a bug, but intended bahaviour. It's now XHTML proof

Derick
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 08:01:24 2021 UTC