php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10762 Call to unsupported or undefined function mysql_connect()
Submitted: 2001-05-09 15:22 UTC Modified: 2001-05-09 15:42 UTC
From: iandbigejunk at yahoo dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.4 OS: Red Hat 7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: iandbigejunk at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-05-09 15:22 UTC] iandbigejunk at yahoo dot com
Problem: php modules for mysql are not loaded.
           Solution: launch php from command line using php -h
           watch and note errors.  In our case these files need renaming from version 10 to version
           9.  See version 9 below.  NOTE links must also be changed.


           [root@hobbes lib]# ll libmy*
           lrwxrwxrwx    1 root     root           23 May  8 14:33 libmysqlclient.so ->
           libmysqlclient.so.9.0.0
           lrwxrwxrwx    1 root     root           23 May  8 14:33 libmysqlclient.so.9 ->
           libmysqlclient.so.9.0.0
           -rwxr-xr-x    1 root     root       217861 Mar 27 02:33 libmysqlclient.so.9.0.0
           lrwxrwxrwx    1 root     root           25 May  8 14:33 libmysqlclient_r.so ->
           libmysqlclient_r.so.9.0.0
           lrwxrwxrwx    1 root     root           25 May  8 14:32 libmysqlclient_r.so.9 ->
           libmysqlclient_r.so.9.0.0
           -rwxr-xr-x    1 root     root       217925 Mar 27 02:32 libmysqlclient_r.so.9.0.0


           If you can enter the command 
           #php -h
           with no errors then your mysql modules are probably loaded ok.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-09 15:40 UTC] cardinal@php.net
Not a bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 05:05:44 2022 UTC