php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10345 unlink ignores permissions
Submitted: 2001-04-16 11:15 UTC Modified: 2001-04-30 02:10 UTC
From: sascha at rizzt dot 2y dot net Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4.0.1pl2 OS: redhat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sascha at rizzt dot 2y dot net
New email:
PHP Version: OS:

 

 [2001-04-16 11:15 UTC] sascha at rizzt dot 2y dot net
unlink seems to run as root.
i have set file permissions to 444 (owner root) and tried to open this file for writing from a script. php said 'permission denied'. then i tried to unlink this file with success.

mod_php-4.0.1pl2-9
apache-1.3.12-25

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-30 02:10 UTC] andi@php.net
This is not a bug but how the filesystem works. Permissions for erasing a file is according to the permissions on the directory and not the file.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Nov 26 23:05:53 2022 UTC