php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10150 Error when compiling Apache 1.3.14+SSL with static PHP4.0.4
Submitted: 2001-04-04 01:47 UTC Modified: 2001-05-06 14:17 UTC
From: joe at ammendolias dot com Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.0.4 OS: Redhat 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: joe at ammendolias dot com
New email:
PHP Version: OS:

 

 [2001-04-04 01:47 UTC] joe at ammendolias dot com
When compiling apache 1.3.14 (with apache-ssl patches applied) and php 4.0.4 (Static) I get the following results:


<...snip...>
gcc  -DLINUX=2 -DTARGET=\"httpsd\" -I/data/apache/php-4.0.4 -I/data/apache/php-4.0.4/main -I/data/apache/php-4.0.4/main -I/data/apache/php-4.0.4/Zend -I/data/apache/php-4.0.4/Zend -I/data/apache/php-4.0.4/TSRM -I/data/apache/php-4.0.4/TSRM -I/data/apache/php-4.0.4 -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED -DAPACHE_SSL `./apaci`    \
      -o httpsd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a modules/php4/libphp4.a main/libmain.a ./os/unix/libos.a ap/libap.a  lib/expat-lite/libexpat.a -lnss_dns -rdynamic -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4  -lpam -lc-client  -ldl -lresolv -lm -ldl -lcrypt -lnsl  -lresolv   -lm -L/usr/local/ssl/lib -lssl -lcrypto
modules/php4/libphp4.a(dns.lo): In function `php_if_checkdnsrr':
/data/apache/php-4.0.4/ext/standard/dns.c:200: undefined reference to `__res_search'
<...snip...>

I saw a similar problem reported (bug# 4739) but as you can see above, I attempted to run configure with the 'EXTRA_LIBS="-lnss_dns" and still no luck. (Actually the configure script reported that EXTRA_LIBS was deprecated and should be replaced with simply LIBS so thats what I did.)


Any suggestions?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-04-04 06:00 UTC] sniper@php.net
Could you please try the latest CVS snapshot from http://snaps.php.net/
as there have been some fixes regarding this.
(and just use the configure line without any LIBS defined)

--Jani

 [2001-05-06 14:17 UTC] jmoore@php.net
No feedback
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jul 19 05:01:30 2024 UTC