php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4757 error on starting apache
Submitted: 2000-06-01 16:05 UTC Modified: 2000-08-20 02:01 UTC
From: markn at pavnet dot co dot uk Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.0 Release OS: RH 6.1
Private report: No CVE-ID: None
 [2000-06-01 16:05 UTC] markn at pavnet dot co dot uk
When starting apache the following error occurs.

Syntax error on line 238 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: v_compile_files

configured with the following commands

./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--with-gd \
--with-gettext \
--enable-track-vars \
--enable-force-cgi-redirect

There were no errors in make or make install


Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-01 16:42 UTC] markn at pavnet dot co dot uk
Apache Version 1.3.12 (binary distribution apache_1.3.12-i686-whatever-linux2.tar.z)
 [2000-06-01 16:57 UTC] markn at pavnet dot co dot uk
Apache Version 1.3.12 (binary distribution apache_1.3.12-i686-whatever-linux2.tar.z)
 [2000-06-01 16:58 UTC] markn at pavnet dot co dot uk
Apache Version 1.3.12 (binary distribution apache_1.3.12-i686-whatever-linux2.tar.z)
 [2000-08-08 22:34 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-08-20 02:01 UTC] sniper@php.net
No feedback from user.
And the --enable-force-cgi-redirect should be used only when compiling 
cgi version.

--Jani

 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 02:00:02 2026 UTC