|
php.net | support | documentation | report a bug | advanced search | search howto | statistics | random bug | login |
PatchesPull RequestsHistoryAllCommentsChangesGit/SVN commits
[1999-09-08 09:09 UTC] sas at cvs dot php dot net
|
|||||||||||||||||||||||||||
Copyright © 2001-2026 The PHP GroupAll rights reserved. |
Last updated: Sun Oct 11 09:00:02 2026 UTC |
This is the configure script I run ./configure --with-apxs=/usr/sbin/apxs --with-config-file-path=/etc --with-mysql=/usr/local/mysql after configure is done then I run make, then this happens near the end of the make process(note the Errors) /usr/sbin/apxs -c -o libphp3.so -I. -I. -Wl,'-rpath /usr/local/mysql/lib/mysql' ./mod_php3.c libmodphp3-so.a -L/usr/local/lib -L/usr/local/mysql/lib/mysql -lmysqlclient -lgdbm pcrelib/libpcre.a -lpam -lm -ldl -lcrypt -lnsl -lresolv -Lpcrelib -lpcre apxs:Error: Unknown option: W Usage: apxs -g -n <modname> apxs -q <query> ... apxs -c [-o <dsofile>] [-D <name>[=<value>]] [-I <incdir>] [-L <libdir>] [-l <libname>] <files> ... apxs -i [-a] [-n <modname>] <dsofile> ... make: *** [libphp3.so] Error 1 [root php-3.0.12]# This error does not occur when I run the configure script without the MySQL option(--with-mysql=/usr/local/mysql) without that option I am able to copy the share module file, restart apache and use the 3.0.12 version no problem at all, however I need to compile in support for MySQL, any idea why the Unknown option: W Error?? I sent this in yesterday but was unclear about the resolution, the recommendation was a newer version of apache(i am running 1.3.3) and the shared module without the MySQL support does work just fine?? Is the issue that I need a newer version of APXS with support for whatever -W does? and APXS is somehow bundled with a newer version of APACHE? When I do not add the --with-mysql in the configure script here are the final lines of the make process, you can see that there is no -W in the apxs command: /usr/sbin/apxs -c -o libphp3.so -I. -I. ./mod_php3.c libmodphp3-so.a -L/usr/local/lib -lgdbm pcrelib/libpcre.a -lpam -lm -ldl -lcrypt -lnsl -lresolv -Lpcrelib -lpcre gcc -O2 -fomit-frame-pointer -DCOBALT_RAQ_LED -DLINUX=2 -fpic -DSHARED_MODULE -I/usr/include/apache -I. -I. -c ./mod_php3.c ld -Bshareable -o libphp3.so ./mod_php3.o libmodphp3-so.a -L/usr/local/lib -lgdbm pcrelib/libpcre.a -lpam -lm -ldl -lcrypt -lnsl -lresolv -Lpcrelib -lpcre [root php-3.0.12]# This results in a shared module that I can add to the apache config and it runs just fine??