|
php.net | support | documentation | report a bug | advanced search | search howto | statistics | random bug | login |
[2002-08-02 05:46 UTC] michel dot jansens at ulb dot ac dot be
I get an linking error when starting apache (DSO compiled): Syntax error on line 231 of /usr/products/apache_httpdevb/conf/httpd.conf: Cannot load /usr/products/apache_httpdevb/libexec/libphp4.so into server: ld.so.1: /usr/products/apache_httpdevb/bin/httpd: fatal: relocation error: file /usr/products/apache_httpdevb/libexec/libphp4.so: symbol ssl_onceonlyinit: referenced symbol not found I've tried different versions of openssl without success. I've done the same on a newer build of Solaris (on another machine) and that one works fine... I compiled the libphp4.so module like this: setenv CC gcc configure --enable-track-vars \ --with-apxs=/usr/products/apache_httpdev/bin/apxs \ --with-imap=/usr/products/imap/imap-2000b \ --with-curl=/usr/products/curl\ --with-informix=/usr/products/informix \ --enable-discard-path \ --with-imap-ssl=/usr/local/ssl0.9.6.e \ --with-open-ssl=/usr/local/ssl0.9.6.e \ --enable-wddx PatchesPull RequestsHistoryAllCommentsChangesGit/SVN commits
|
|||||||||||||||||||||||||||
Copyright © 2001-2026 The PHP GroupAll rights reserved. |
Last updated: Tue Oct 06 15:00:01 2026 UTC |
Your configure line is wrong. --with-open-ssl=/usr/local/ssl0.9.6.e \ ^ it should be --with-openssl=...